[2026-06-18 18:04:42] - Incident status was updated.
Summary: The incident has been resolved. Traffic has returned to expected levels with no further impact currently observed.
Posted Jun 18, 2026 - 18:21 UTC
Monitoring
[2026-06-18 15:31:24] - Incident status was updated.
Summary: Signs of recovery are being observed with traffic levels returning to normal and remote testing showing successful results. Network monitoring will continue over the next few hours to confirm full stability.
Posted Jun 18, 2026 - 15:41 UTC
Update
[2026-06-18 13:51:53] - Incident status was updated.
Summary: Investigating connectivity issues in the United Kingdom affecting devices attempting to roam on a specific network. Devices may be unable to register or experience unstable data and SMS services. The issue appears isolated to one network only, with other networks operating normally. Network partners are investigating and further updates will be provided as information becomes available.
Posted Jun 18, 2026 - 14:01 UTC
Investigating
Connectivity issues affecting mobile network registration and data services in the United Kingdom. Devices may be unable to register or experience unstable data services on affected network.